Service Disruption Due to Upstream Provider Outage

Incident Report for Quikirr

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:00 UTC

Update

Service functionality is gradually being restored as our upstream provider mitigates the issue. Some users may already see improvements, while others may still experience degraded performance. We are continuing to monitor closely and will provide a final update once full stability is confirmed.
Posted Jun 12, 2025 - 20:20 UTC

Monitoring

We are currently experiencing a service disruption due to issues with one of our upstream infrastructure providers. Our team is actively working with them to resolve the issue and restore full functionality. We will continue to provide updates as more information becomes available.
Posted Jun 12, 2025 - 19:58 UTC
This incident affected: Quikirr.